Okay
  Public Ticket #1787965
Outdated Fancybox
Open

Comments

  • banggraphics started the conversation

    Hello,

    I am trying to get the ARI fancybox plugin (https://wordpress.org/plugins/ari-fancy-lightbox/) to work with the theme.

    I am told there are conflicts by its developer and they are saying the theme has an old version of the fancybox library (https://wordpress.org/support/topic/cannot-set-property-vimeo-of-undefined/#post-10892923).

    Could you please offer any help with the situation? How might I update the fancybox library in the theme?

    Thanks in advance!

  •  113
    Alexandre replied

    Hi, 
    I working on your request. I will contact you soon as possible

    Thank you,

    --

    Alexander

  •  113
    Alexandre replied

    Hi there, 

    The problem occurs because your theme uses Fancybox library and it causes conflicts. It is defined in /themes/croma/js/plugins.all.min.js file. Sorry but our theme is not compatible with ARI fancybox.

    Thank you,

    --

    Alexander

  • banggraphics replied

    Ah I see ok.

    Thank you for looking into it.

  •  113
    Alexandre replied

    You are welcome

    Thank you,

    --

    Alexander

  • banggraphics replied

    Hello,

    Could you please give assistance as to how to create my own fancybox links?

    I do not wish to use the video gallery as I want to design my own. I have tried to use many of the varying ways that the fancybox script can be called upon that I can find but none seem to work.

    Can you please offer any advice?

    What I wish to achieve is to have a link that when clicked opens up a lightbox with a video in it.

    Many thanks in advance!

  •  113
    Alexandre replied

    Hi,
    If you are using the croma video custom post feature, you can use the video grid template as we have done here:
    http://croma.irontemplates.com/lowtempo/videos-grid/

    Otherwise you can built a video grid with the Essential Grid plugin.

    Thank you,

    --

    Alexander

  • banggraphics replied

    I do not want to create a video grid.

    I would like to know what code to apply to a link so that it opens in a lightbox.

    The methods I have tried have not worked.

  • banggraphics replied

    As the theme conflicts with all lightbox plugins I try I need to know how how to apply the correct code which works with the way you have coded it.

  •  113
    Alexandre replied

    Sorry but I cant help for this. This is beyond the scope of our support.

    Thank you,

    --

    Alexander

  • banggraphics replied

    Your theme creates a conflict with all other lightbox plugins yet you won't give advice on how to use the code we are stuck with?

    That is terrible. Really bad service.

  •  113
    Alexandre replied

    Hi there, 

    Our theme has already a lightbox option to display the video post. The lightbox from the plugin Essential Grid works well. I hope you understand we cant make our theme compatible with all plugins. 

    Thank you,

    --

    Alexander

  • banggraphics replied

    I am not trying to argue, I am just frustrated.

    I do understand that you can't make your theme compatible with all plugins.

    What I do not understand is that due to the lightbox code your theme uses I have no other options and it doesn't seem to follow the call to actions that the fancybox library suggests that I use.

    As you suggested ... I tried to use the essential grid plugin and it does not work. It doesn't display the videos at all. They are there but for some reason hidden.

    So in order to follow your suggestion to use what works well ... I can not. It doesn't function as expected.

    I thought it could be conflicting CSS that I wrote but it also doesn't work when I remove my CSS either.

    Incidentally did you pop onto the site earlier? The homepage has changed.

  •  113
    Alexandre replied

    Hi, 

    I didnt log into your site today. 

    About the video lightbox, 
    Please tell me which video you want. Where do you want it. 
    Do you want to display only one video or a video grid?
    I will take look.

    Thank you,

    --

    Alexander

  • banggraphics replied

    I have been trying to display on the homepage. You'll see a large white gap where they appear in the code but not visually. They seem to have CSS hiding them somewhere. 

    At the moment I don't know how I may want to display the videos because I can not get them to work to see style and where they may fit.

    I would like the opportunity to display a single video and potentially a video grid in different places.

    If you are able to please get it to work and to drop any of the videos that came as part of the theme demo I can work with it from that point.

  •  113
    Alexandre replied

    I dont have time right now. 
    I have to go, but I will take a look tomorrow morning.

    Thank you,

    --

    Alexander

  •  113
    Alexandre replied

    Hi,

    May I update your croma theme and croma-music?

    For now a JS error make the video feature crash. I dont know why this happen. I want to make your theme up to date before i spend more time to the investigation.

    Thank you,

    --

    Alexander

  • banggraphics replied

    Yes mate. Go for it.

  •  113

    Thank you,

    --

    Alexander

  •  113
    Alexandre replied

    I have removed Croma to install the new version but it is impossiible to install another theme, because 
    the uploaded file exceeds the upload_max_filesize directive in php.ini. 

    Could you please contact your webhost provider so they can increase the ax uploading file size. 
    Or provide to me a ftp access so I will be able to re-install croma. 

    Sorry for this situation. My purpose to offer you to update your theme myself was only to save time and be helpful. 

    Thank you

    Thank you,

    --

    Alexander

  • banggraphics replied

    Is this the version downloadable from themeforest?

    If so ... I have just downloaded it put it up there for you.

  •  113
    Alexandre replied

    Yes you can download it from themforest.

    Thank you,

    --

    Alexander

  • banggraphics replied

    Then it's sat on the site ready for you sir.

  •  113

    Thank you,

    --

    Alexander

  •  113
    Alexandre replied

    So now the grid on the homepage and on this page (http://bangtesting.uk/rizzo/videos-grid/) work fine

    Thank you,

    --

    Alexander

  • banggraphics replied

    Thank you.

    Do you know what caused it to cease working?

  •  113
    Alexandre replied

    And I have set the grid action to "lightbox"




    Thank you,

    --

    Alexander

  • banggraphics replied

    Also ... would you mind please fixing the previous issue please?

    Updating the theme has overwritten the changes you made.

    When you click on an audio image, then click another one and then click back to a previous one it doesn't play the audio.

  •  113
    Alexandre replied

    You right, 
    I have fixed. 
    dont worry the fix will be in the next theme uodate.

    Thank you,

    --

    Alexander

  • banggraphics replied

    Thank you.

    I remember you saying.

    Right ... i'm off to see if I can make these grids look how I want them to.

    Have a good weekend.

  •  113
    Alexandre replied

    You are welcome

    Thank you,

    --

    Alexander