Okay
  Public Ticket #1753750
Error with jquery in Chroma
Closed

Comments

  • shikkaba started the conversation

    Hello,

    I have a problem currently when I load the main page again from another page. Many javascript elements stop working, and there is one piece of code that continues to try to function and doesn't stop.

    The issue appears to be with jquery.

    You can reproduce this error by visiting the site link, going to another page, and then clicking on the logo to bring you back to the main page.

    This issue does not happen while visiting the home page directly, or by clicking on the home page link from the home page.

    There is a testimonial plugin added, but this error happens even with that plugin uninstalled.

    Please help.

    Attached files:  errors.jpg

  •   shikkaba replied privately
  •  61
    Maxime replied

    Hi,

    Perhaps its a conflict with one of your third party plugins. Could you try something for me? Please deactivate all your plugins except WPBakery Page Builder, Essential Grid and Revolution Slider then see if the issue persists. If not, please reactivate your plugins one by one and see which plugin can cause the conflict. Tell me how it goes.

    Thank you,

    --

    Maxime

  • shikkaba replied

    Hi,

    As I mentioned, this issue happened even with the plugin uninstalled. I had already tried uninstalling the plugins not with the theme and the same issue happened.

  •  61
    Maxime replied

    Ok,


    Could you please update your theme to the latest version please?

    How do I update my theme ?

    Thank you,

    --

    Maxime

  • shikkaba replied

    Done. Issue still persists.

    Also, I'd like to note that this same issue appears in your demo (http://croma.irontemplates.com/lowtempo/) which is the same demo I based the site off of, by doing the same steps:

    - Go to the main page and visit another page
    - Click on the logo to visit the main page

    You can see the problem visibly as the Instagram widget does not work when you go back to the main page from another page.

  • shikkaba replied

    Sorry, one more thing. After updating the theme, the Instagram portion of the demo content broke.

    All I did was deactivate the theme plugins, uninstall them, then reinstall the newer versions from the theme plugin installer. I was hoping to be able to use this feature.

    EDIT: This part appears to be because the plugin was uninstalled and reinstalled. Could you please add a way to update your plugins without uninstalling and reinstalling? It did not indicate there was an update for plugins after installing the themes which is why the plugins were uninstalled.

  • shikkaba replied

    Hi,

    I found the issue. The problem is with your "Enable Continious Audio Player and AJAX" setting. Turning this off fixed the problem, and you may find it'll fix the issue on your demo as well.

    That's too bad because the menu staying in the top looks really cool.

    Is there any chance that this issue will be fixed in the near future? I realize it was a beta feature, but it is really cool looking.

  •  113
    Alexandre replied

    Hello Shikkaba, 

    Just want to let you know, I m logging to your site right now to investigate the ajax issue.

    Thank you,

    --

    Alexander

  •  113
    Alexandre replied

    Ok the issue is a conflict between The "Ajax continuous player", as you have reported, and the option "show menu over content" enable.

    I m working on this issue. 

    I will contact you soon as possible

    Thank you,

    --

    Alexander

  •  113
    Alexandre replied

    Here our documentation about how to update plugin.
    https://irontemplates.ticksy.com/article/12214/

    Thank you,

    --

    Alexander

  •  113
    Alexandre replied

    Hello, 

    I have fixed the issue in our theme, but the "Testimonials Showcase"  plugin still have a conflict with the "Ajax continous audioplayer". 

    Now, the theme will work if you desable "Testimonials Showcase" and activate the "Ajax continous audioplayer".

    Thank you,

    --

    Alexander

  • shikkaba replied

    Is there a way to turn off the player or remove it? I'd tried removing the block for it from that pages layout, but it didn't work.

    I want the ajax effect, but not the continuous player.

  •  113
    Alexandre replied

    Hello Shikkaba,

    The continuous player should not appears if you dont start a album. Are you using the discogrphy feature?

    Thank you,

    --

    Alexander

  • shikkaba replied

    No, I am not using that feature.
    Sorry, I meant to reply a while ago. You can close this ticket as the issue doesn't come up while that feature is turned off.

    Thank you!